Advertisement






Arbitrary code execution through SVG import

CVE Category Price Severity
CVE-2021-12345 CWE-434 $500 Critical
Author Risk Exploitation Type Date
ExploitMasterX High Remote 2005-10-06
CVSS EPSS EPSSP
CVSS:4.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H 0.94441 0.99704

CVSS vector description

Our sensors found this exploit at: http://cxsecurity.com/ascii/WLB-2005100018

Below is a copy:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200510-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
     Title: Dia: Arbitrary code execution through SVG import
      Date: October 06, 2005
      Bugs: #107916
        ID: 200510-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Improperly sanitised data in Dia allows remote attackers to execute
arbitrary code.

Background
==========

Dia is a gtk+ based diagram creation program released under the GPL
license.

Affected packages
=================

-------------------------------------------------------------------
     Package         /  Vulnerable  /                       Unaffected
    -------------------------------------------------------------------
  1  app-office/dia      < 0.94-r3                          >= 0.94-r3

Description
===========

Joxean Koret discovered that the SVG import plugin in Dia fails to
properly sanitise data read from an SVG file.

Impact
======

An attacker could create a specially crafted SVG file, which, when
imported into Dia, could lead to the execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Dia users should upgrade to the latest version:

# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/dia-0.94-r3"

References
==========

[ 1 ] CAN-2005-2966
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2966

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200510-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security (at) gentoo (dot) org [email concealed] or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Copyright ©2024 Exploitalert.

All trademarks used are properties of their respective owners. By visiting this website you agree to Terms of Use.