Advertisement






CKSource CKEditor5 35.4.0 Cross Site Scripting

Our sensors found this exploit at: https://cxsecurity.com/ascii/WLB-2023020019

Below is a copy:

CKSource CKEditor5 35.4.0 Cross Site Scripting
# Exploit Title: Cross Site Scripting in CKSource's CKEditor5 35.4.0
# Google Dork: N/A
# Date: February 09, 2023
# Exploit Author: Manish Pathak
# Vendor Homepage: https://cksource.com/
# Software Link: https://ckeditor.com/ckeditor-5/download/
# Version: 35.4.0
# Tested on: Linux / Web
# CVE : CVE-2022-48110



CKSource CKEditor5 35.4.0 was discovered to contain a cross-site scripting
(XSS) vulnerability via Full Featured CKEditor5 Widget as the editor fails
to sanitize user provided data.

An attacker can execute arbitrary script in the browser in the context of
the affected site. This can allow the attacker to steal cookie-based
authentication credentials and launch other attacks.

CKEditor5 version 35.4.0 is tested & found to be vulnerable.

Documentation avaiable at
https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.html#security

Security Docs Says """The HTML embed feature does not currently execute
code in <script> tags. However, it will execute code in the on* and
src="javascript:..." attributes."""



Payload:

<div class="raw-html-embed">
    <script>alert(456)</script>
</div>

Copyright ©2024 Exploitalert.

All trademarks used are properties of their respective owners. By visiting this website you agree to Terms of Use.