Advertisement






FoF Pretty Mail 1.1.2 Command Injection

CVE Category Price Severity
CVE-2021-32660 CWE-78 $5,000 High
Author Risk Exploitation Type Date
Unknown High Remote 2024-03-30
CPE
cpe:/a:fof_pretty_mail:fof_pretty_mail:1.1.2
CVSS EPSS EPSSP
CVSS:4.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H 0.81 0.76

CVSS vector description

Our sensors found this exploit at: https://cxsecurity.com/ascii/WLB-2024030073

Below is a copy:

FoF Pretty Mail 1.1.2 Command Injection
Exploit Title: FoF Pretty Mail 1.1.2 Extension for Flarum Command Injection
Date: 03/28/2024
Exploit Author: Chokri Hammedi
Vendor Homepage: https://flarum.org/
Software Link: https://github.com/FriendsOfFlarum/pretty-mail
Version: 1.1.2
Tested on: Windows XP
CVE: N/A
Description:

The FoF Pretty Mail extension for Flarum is vulnerable to Command Injection
due to the unsafe handling of user input in the email template. An attacker
with administrative access can inject PHP code into the email template,
leading to arbitrary command execution on the server.

Steps to Reproduce:

Log in as an administrator on the Flarum forum.
Navigate to the FoF Pretty Mail extension settings.
Edit the email default template and insert one of the following payloads at
the end of the template:

<?php system('echo "Take The Rose"; id'); ?>
or
<?php system('echo "Take The Rose"; cat /etc/passwd'); ?>

Save the changes to the email template.
Trigger any action that sends an email, such as user registration or
password reset.
The recipient of the email will see the message "Take The Rose" followed by
the output of the injected command (id or cat /etc/passwd) in the email
content.

Copyright ©2024 Exploitalert.

All trademarks used are properties of their respective owners. By visiting this website you agree to Terms of Use.