Advertisement






Human Resource Information System 0.1 | Persistent Cross-Site Scripting (Authenticated)

CVE Category Price Severity
CVE-2021-28301 CWE-79 $500 High
Author Risk Exploitation Type Date
Unknown High Remote 2021-05-17
CPE
cpe:cpe:/a:exploitalert:human-resource-information-system:0.1
CVSS EPSS EPSSP
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H 0.02192 0.50148

CVSS vector description

Our sensors found this exploit at: https://cxsecurity.com/ascii/WLB-2021050096

Below is a copy:

Human Resource Information System 0.1 | Persistent Cross-Site Scripting (Authenticated)
|===========================================================================
| # Exploit Title : Human Resource Information System  0.1 | Persistent Cross-Site Scripting (Authenticated)
|                                                                           
| # Author : Ali Seddigh                                               
|                                                                           
| # Category : Web Application               
|
| # Vendor Homepage: https://www.sourcecodester.com
|
| # Software Link: https://www.sourcecodester.com/php/14714/human-resource-information-using-phpmysqliobject-orientedcomplete-free-sourcecode.html
|
| # Software Download: https://www.sourcecodester.com/download-code?nid=14714&title=Human+Resource+Information+System+Using+PHP+with+Source+Code
|                                                                           
| # Tested on : [ Windows ~> 10 ]                                                     
|
| # Version : 0.1
|                  
| # Date : 2021-05-15                                                        
|===========================================================================

# --- Description --- #

# The web application allows for an  assisstant to inject persistent Cross-Site-Scripting payload which will be executed in both assistant and Super Admin panel  


# --- Proof of concept --- #

1- Login as Assistant and go to:  http://localhost/code/Admin_Dashboard/Add_employee.php
2- Click on Add Employee button
3- Inject this payload into First Name input : <script>alert('xss')</script> 
4- and fill other inputs as you want (Other inputs might be vulnerable as well) then click on Save button.
5- refresh the page and Xss popup will be triggered.

6- Now if Super Admin visit this page in his/her Dashboard : http://localhost/code/Superadmin_Dashboard/Add_employee.php
7- Our Xss payload will be executed on Super Admin Browser

** Attacker can use this vulnerability to take over Super Admin account **

|===========================================================================
| # Discovered By : Ali Triplex                                             
|===========================================================================

Copyright ©2024 Exploitalert.

This information is provided for TESTING and LEGAL RESEARCH purposes only.
All trademarks used are properties of their respective owners. By visiting this website you agree to Terms of Use and Privacy Policy and Impressum